プラグインが最新のPHPに対応してないことも多い

あるサイトで使われてたプラグイン。WP jQuery Lightbox

2年更新が止まってるとWordfenceから警告メールが来たので別のプラグインに変更した。Simple Lightbox

これもローカルで動かしてみるとcreate_function使っててエラー。GitHub見ると確かに使ってる。PHP5.2対応とするなら仕方ないけど。PHP7.2でもまだ本番環境では問題なく動く。WordPress本体の必要バージョンが上がるのを待つのみ…。

テーマなら修正するけどプラグインの場合は別のプラグインに再度変更するだけ。プラグインの修正までは面倒見きれない。

WordPress本体を改造したりプラグインをカスタマイズして使いたがる人がいるけどそれは絶対にしてはいけないこと。自動更新できなくなる。

昔手伝ったWordPressは本体改造してたけど今見に行ったらリニューアルして普通の使い方になってた。あのままじゃどうしようもなくなってただろうから当然。それでも最新バージョンは使えてないけど。4.7.2で止まってる。